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· Appendix A. Excel Tutorial

A.1 Excel Basics

A.1.1 Window
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· Title Bar - top row of window which contains the name of the program (Microsoft Excel) and the name of the workbook you are in. 

· Office Button – the large button in the top-left corner with the Office logo. Most of the file control commands are here (open, close, save, etc.).

· Ribbon – where all the buttons are organized in tabs or in the office button.
· Buttons - shortcuts to various options and commands within Excel. Each button has an icon on it to help you remember what it does. To start the function, click on the button. 

· Formula Bar - located under any toolbars you have selected. It displays the current cell address and contents. It is divided into three sections by vertical lines. The second and third sections only come alive when you type something into the cell. Whenever a cell contains a formula, the formula will be displayed here. 

· Status Bar - at the very bottom of the window. It displays information about the current state of Excel.

· Document Window - located right below the formula bar. It has various features along its edges. 

1. Scroll bars - for moving the spreadsheet vertically and horizontally. 

2. Sheet tabs - for displaying the first six sheets of the workbook. Click on the appropriate tab to activate a new worksheet (bringing it to the top for display). 

3. Cell letters and numbers - letters across the top of the window and numbers along the left-hand side. The letters and numbers are the titles of the columns and rows within the spreadsheet. They fix the location of the various cells by specifying the column and row each cell is in. The current active cell has its column letter and row number displayed in the first part of the formula bar. 

A.1.2  Spreadsheet Components 

· Spreadsheet - collection of cells in rows and columns in which data and equations can be entered. An equation in one cell can operate on data in other cells. Two major features help you save time doing data analysis. 

1. Equation copying - spreadsheets allow you to copy an equation that is valid for a whole column (or row) of data. Excel automatically figures out the appropriate data for each row to use in the equation. Therefore, you are only required to type a given equation one time. 

2. Data updating - results are automatically recomputed if you change any of the data in the spreadsheet. Therefore, once again, if you want to make the same computations with multiple data runs, you only type the equations once. Also, if you make a mistake inputting the data (e.g., you messed up the units the first time you entered the data), then make your corrections to the data and the results are recomputed for you everywhere in the spreadsheet that data is used. 

· Workbook - collection of worksheets, charts, and macro sheets which are saved as a single file. Contains 3 blank worksheets to start. 

· Worksheet - another name for a spreadsheet. Each worksheet has cells organized in a series of 256 columns and 16,384 rows. 

· Active Cell - the selected block within the spreadsheet which is formed by the intersection of column and row gridlines. The cell is selected by clicking on it. The active cell is shown by a heavy outline. It is referenced by its column letter and row number. 

1. Relative cell reference - the column letter followed by its row number. 

2. Absolute cell reference - indicated by placing a dollar sign in front of the column letter and also in front of the row number. Absolute references in formulas don't change when you copy the equation. 

A.1.3 Basic Features 

· Beginning and Ending
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1. New workbook - click on the Office Button, then on New. Follow the directions in the dialog box that appears. If you already had an open workbook, the new workbook appears on top of it.

2. Naming and saving the workbook - click on the Office Button, then on Save As. In the dialog box that appears, first choose a name for your workbook (e.g., “Tutorial”). Next, choose a location on which to save the file (c: to store on the hard drive). Finally, choose a directory/folder for you workbook and then press OK. Note that the title at the top of the window has changed to the name you typed in. The file is actually stored as “name.xls”. Periodically you should resave your workbook. To do this, click on Save instead of Save As in the Office Button menu. Alternatively, click on the floppy disk icon in the title bar next to the Office Button to save the file with its current name.
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3. Naming worksheets – double click the active sheet tab in the lower left corner (it should turn black), type your new name and hit enter. Note that the name you typed now appears on the sheet tab at the bottom of the window. 

[image: image4.png]@Eﬂ: nple

[ vome |_imsent__rageoout__Fomuss__Data ot

b ara <o - [& x| (= ] | Srwptet [Genera & ()
Paste e Conditional Format  Cell
2 pomatpamer | (B 5 [E][00 A s Ceries | A Bt e sy
Gipboara 5 Algnment 5l Number soes
85 -
A _[.B | E F G H 1 J K L M N

—

newlame , acclrtion oble deta set 2 23 AN I

bR LR N R eSS Sl el




4. Closing and opening workbooks - click on Close from the Office Button menu. If you have not yet saved the workbook, you will be prompted to do so. After closing the workbook, you can open a previously existing workbook by clicking on Open from the Office Button menu (or clicking on the floppy disk icon in the Title Bar). You need to select the appropriate drive and folder that the file is stored in. Click on the file you want and then press OK. The workbook will appear in your window. 

5. Quitting Excel - click on Exit Excel from the Office Button menu. 

· Entering Text and Data

1. 
Typing method 

· Select a cell (e.g., cell A1) by clicking in it
· Type into the cell the words you want to appear. For example, type “Purpose: Excel basics” in cell A1. Press Enter when finished. Note that the words appear both in the selected cell and in the formula bar. 

· Correct any mistakes by clicking first on the cell, then on the text in the formula bar. Use delete and other keys to make corrections and then press Enter when finished. 

2. Series method - for typing in a series of numbers. 

· Small series - type the first number of the series into the first cell (e.g., type '10'1 into cell A3 and then press Enter). Highlight cells A3 to A12 by clicking on cell A3 and then dragging the pointer down to cell A12 and then releasing the left mouse button (the top cell will be clear while the rest are dark). On the Home tab under the Editing section click Fill then Series. In the dialog box that appears, choose Columns, Linear, and Step Value of 10. Press OK and the series 10 to 100 will appear in cells A3 to A12. 
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· Large series - type in the first number as before, but don't highlight the cells (too many). Click on Home, Fill (under Editing), and Series from the ribbon. In the dialog box, fill in as before, but place a number in the stop value. Click OK and see your series. 

· Clearing a series - highlight the series and then from the Editing section, click on Clear and then on Contents from the submenu. Alternatively, after highlighting the series, right click with your mouse. From the menu that appears, select Clear Contents. 

· Formatting the Spreadsheet 
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1. Labels - type in descriptive labels for columns of numbers that you have in your spreadsheet. For example, in cell A2, type “Angle (deg)”. Press Tab to go to cell B2. Type “Angle (rad)” in cell B2. Type “
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“ in cell C2. To get 
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, you must go to the Ribbon and click on the Insert tab then click on Symbol. In this new window pick the “Greek and Coptic” subset and scroll down a bit, double click on theta when you see it. Get used to this because we use a lot of greek letters as variables in Physics. Type “Vx (m/s)” in cell D2, “Vy (m/s)” in cell E2, and “Velocity (m/s)” in cell F2. Note that some labels overlap labels from other cells. We will fix this in a moment. 

2. Inserting and deleting rows and columns - to add rows, go to the left side of the window and click on the row number above which you want to insert a new row (e.g., click on row 2). Note that the whole row is now dark. On the Home tab click the Insert button from the Cells section. To delete a row, highlight the row by clicking on its number, then click on Delete from the same place. To insert or delete columns, repeat the process, but choose Column instead of Rows. As an alternative for each of the above processes, click your right mouse button after highlighting the appropriate row or column. Insert and Delete commands will be listed in the menu that appears. Click on the one you need. 

3. Adjusting column widths 

· Absolute width method - click a cell in the column to be adjusted (e.g., click A3). From the Home tab, click Format from the Cells section and then Column Width. In the dialog box, type the number you want for the width (e.g., 12) and then click OK. 
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· Dragging the size method - place the mouse pointer over the right-hand border of the column header of the column you want to change. After the pointer changes shape to a bar with a double-sided arrow, drag the border until the column is wide enough. 

· Auto fit method - select the column to be adjusted by clicking on its header letter. From the same Format Button on the Home tab, click on Autofit Column Width. The column automatically adjusts so that the largest item in any row of the column will fit. If you choose column A, the autofit will produce a column way too big because of the words in cell Al. If you get something you don't want, go back and do one of the previous two methods. 

· Simple auto fit method - simply double-click on the right-hand border of the column. Finish adjusting columns A through F to make sure each label is completely visible. 

4. Styles 

· Selected cells - after highlighting the cells you want to change, select the appropriate button on the Formatting toolbar. For example, highlight cells A3-F3 and click the B on the Home Tab under Font to make the labels boldface. You will have to reformat. 

· Individual characters - highlight the appropriate characters and then select the button you want on the Formatting toolbar. 

· Example styles 

a. Number format - increasing or decreasing the number of digits shown by Excel. First highlight the cells with the digits that are to be changed. Click on either the Increase Decimal button or the Decrease Decimal button, on the Home Tab in the Number section.
b. Greek letters - after highlighting the letter to change, click on the down arrow on the right-hand side of the font window. Choose the symbol font. The English letter will change to a corresponding Greek letter (e.g., r changes to 
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, q to 
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, p to 
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, d to 
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, and D to 
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). 

c. Greek letters (alternate) – when you want a Greek letter click on the Insert Tab and click the Symbol Button. In the new window choose the Greek and Coptic Subset and scroll down a little bit to see the lower case Greek letters. Double click your desired symbol.

· Entering Formulas 

1. Typing method - select the cell for the formula and type an = sign. Next, type in the formula using the appropriate cell identifying letters and numbers. If you need -a special function, Excel has some built in formulas that you can access by clicking on the Formula Tab and then hit the Insert Function Button (or click on the fx icon). In the Insert Function dialog box, select the Math & Trig category and then scroll through the list until you find the appropriate function. For example, to change the 10 degrees in cell A4 to radians in cell B4, type “= (A4/180)*PI()” in cell B4 and then press Enter. You can either type “PI()” yourself or select it from the Insert Function dialog box. Note that after you press Enter, the typed in formula remains in the function bar while the cell displays the number calculated from the formula. 
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2. Clicking and typing method - same as above, except instead of typing cell references each time, you can just click on the cell itself. For example, in cell C4 type the = sign and then “cos(”. Next, click on cell B4 and the formula will read = cos(B4.
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Finish by typing the remaining parentheses and then pressing Enter. For cell D4, type “= 5*” and then click on cell C4. This will calculate an x component of the velocity which equals 5*
[image: image17.wmf]cos

q

. In cell E4, type “= 5*sin(”, click on cell B4, and finish with “)”. To calculate the magnitude of the velocity we use the Pythagorean formula. In, cell F4, type “= sqrt(”, then click on cell D4, then type “^2 +”. The carrot symbol tells Excel to raise the previous entry to the power of the following number. Finish by clicking on cell E4 and then typing “^2)”. After pressing enter, the cell should read a velocity of 5. 
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3. Fill down method - allows you to copy equations into other cells and have the row numbers automatically changed. For example, highlight B4 through F13, then in the Home Tab, under Editing click on the Fill Button and then on Down. Your table fills up with numbers calculated from the copied equations. Note that as you move down from cell to cell in a column, the equation in the formula bar has the appropriate row number. If you did this step correctly, the last column should have every cell displaying a 5.
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4. Copying and pasting method: another method for copying equations. Select the cell with the equation to be copied and then from the Home Tab under Clipboard click Copy. Alternatively, after selecting the cell, to copy it simply press Ctrl-C (press the Ctrl key and the C key at the same time) or right click on the highlighted cell and click on Copy from the menu that appears. When a cell or range of cells is on your clipboard it is surrounded by a flashing dashed box. Next, highlight the cells in which you want to copy the equation and press Enter or Ctrl-V (for paste) or once again right click your mouse and select Paste from the menu that appears. 
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· Printing the Spreadsheet 

1. Without preview - simply choose Print from the Office Button menu.
2. With preview - click on the arrow next to Print from the Office Button menu and in the right window choose Print Preview. The worksheet as it will print is shown. You can zoom in on various features if you wish or change the margins. If you like the way it looks, you can print from this screen. 
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A.2 Data Analysis Tutorial 

A.2.1 Table Preparation 

· Select Worksheet 

1. Click sheet2 tab - a new worksheet comes to the front of the window. 

2. Name the worksheet – by double clicking on its tab and type “acceleration table”. Alternatively, right click-on the tab to rename it. 

· Organize Table 

1. Name and section - in cell Al, type “Name: your name”. Press Tab to go to the next cell and then type “Section: your lab day and time”. 

2. Description of table purpose - in cell A3, type “Purpose: to calculate the acceleration of a failing object”.

3. Data set identification - in cell A4, type “Data set 1: One Dimension”. 

4. Table labels - skip a row and type labels for each column in row 6. column headings should be: “Data No.”, “time(s)”, “Distance(m)”, “Mid-Time(s)”, “Velocity(m/s)”, and “Acceleration (m/s2)”.  

5. Format as needed 

A.2.2 Data Entry 

· Data Number - starting in cell A7 (directly under the heading “Data No.”), enter the number “1”. Highlight cell A7, then select Edit 
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 Fill 
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 Series from the menu bar. In the dialog box choose Columns, Linear, Step Value of 1, and Stop Value of the number of frames you are using (ie 12). 

· Time Data - starting in cell B7, enter “=A7/fframerate”.  Highlight cells B7 to B18, then select Edit 
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 Fill 
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 Down.  Note there is no need to enter a stop value since Excel will only fill up the cells you have highlighted.

· Distance Data – starting in cell C7 enter the following distances into the D column: 0.033, 0.084, 0.129, 0.162, 0.188, 0.204, 0.209, 0.197, 0.197, 0.178, 0.143, 0.094, and 0.033 (if you have the data you collected in the lab, insert your data in the cells instead).
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A.2.3 Formulas 

· Midpoint Time Column - select cell D7 to enter the formula. Type “= (B7 + B8)/2. This time, to fill in the column, select D7 and then press Ctrl-c to copy the formula. Next, highlight D8 to D17 and then press Ctrl-v to view copies of the formula in each of the cells. Again, check a few cells to make sure the formulas are correct. 

· Average Velocity Column - select cell E7 to enter the formula. Type in “= (C8 - C7)/(B8 - B7)”. Copy the formula by right clicking on cell F7 and then selecting Copy from the menu that appears. Paste the formula by highlighting cells E8 to E17 and then simply pressing Enter. 

· Average Acceleration Column - this time, select F8 to start the formula (since the accelerations will correspond to the times listed in column D), type “= (E8 - E7)/(D8 - D7)”. Once again, copy and paste the formula into the remaining cells of the column.  Note that there is one more open space (F7) that is not filled due to the way we calculate the average.  In E20 enter “Average Accel:”, press Tab and enter “AVERAGE(F8:F17)” then finally hit Enter.
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A.2.4 Graphing 

· Highlight Two Columns: Highlight the two columns containing the x and y data. Make sure to include the labels when you highlight. The x data should be to the left of the y data. Press the Ctrl key while highlighting the second column. For example, highlight column B from B6 to B18, then while pressing Ctrl, highlight column C from C6 to C18. 

· Click on the Insert Tab and pick Scatter and Scatter with Only Markers 
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· To see the Chart Tools/ Tabs you must have a chart actively selected!!! Excel hides these tabs if you don’t tell it what chart you’re working on.
· Click the Select Data Button now under the Chart Tools/Design Tab. It should interpret what your Series Title is from your Column titles. If it doesn’t you can manually check either the cell range, here that would be $B$6:$C$16, or cross check your Horizontal Axis values list with what you have in the chart. This switch Row/Column button is very, VERY IMPORTANT because that is the most common mistake students make on reports.
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· On the Chart Tools/Layout Tab go through all the following: 

· Chart Title: click on the Chart Title button and make sure it is set to Above Chart. Then to edit the title single click on the actual title and enter “Distance of Fall vs. Time – One Dimension”. 
· Axis Titles: For the Primary Horizontal choose Below. For the Primary Vertical choose Rotated Title. For the names edit them the same way: click on them and type “Time (s)” for Value(X) and “Vertical Distance (m)” for Value(Y). 

· Gridlines – choose Major for both Primary Horizontal and Primary Vertical.
· Legend - click none. We will use this when we have more than one data set on the same set of axes. For now we don’t so it’s not necessary.
· Data Labels - none.
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· Now we should move the chart to a new sheet so it doesn’t get in the way and it will print on its own page when we print. Right click on some white space in the chart and choose Move Chart. In the new window choose New Sheet and give it a descriptive name such as “dist. Vs. time”.
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· Select or Deselect the Chart - in order to modify the chart or move it. When selected the chart will have “handles” showing at the corners and the sides of the chart. 

· Resizing the chart: you can manually resize the chart by pulling on the handles on its sides but Excel 2007 defaults to take up the entire page with a chart that is on its own sheet so you probably don’t want to do this.
· Editing the chart: right click your mouse on any chart feature that you want to edit. 

· Curve Fit the Data (if desired) - Excel determines the best curve that fits your data. Excel calls this process the calculation of a “trend line”, although for a linear fit, it is better known as least squares fitting. All you have to do is right click on one of the data points (which will then turn yellow) and then select Add trend line in the menu which appears.
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· Polynomial fit - click on Polynomial for the Trend/Regression Type. For the order, choose 2 for a quadratic fit. For example, our plot of distance vs. time should result in a parabola which is a 2nd order Polynomial. Click the Options tab to specify more details of the trend line. If your data doesn't cross the y-axis, you need to enter a number in the Backward Forecast Field. You may also want to put a small number in the Forward Forecast Field. Check the box for Display Equation on Chart. Excel will calculate the equation of the parabola it thinks best fits your data.  
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If needed, click and drag the equation to a more readable location on the chart (under the title is a good location). Note that the coefficient in front of the x2 term is approximately g/2. 
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· Linear fit - click Linear for Trend/Regression Type. Click on the Options tab and select the appropriate options as described above. You should now go back and create a chart for velocity vs. the midpoint time (columns E and F.) and use the linear fit trendline to determine the acceleration from the slope of the line. It should be approximately 9.8 m/s2.  Scale the axes (by right clicking on the numbers) so that the data points stretch from the bottom left corner of the graph to the upper right corner. Make sure the intercept shows on the graph.
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A.2.5 Fine tuning the trend line

· Excel provides a variety of options for fine-tuning the trend line you add to a data set. These options include inserting the equation of the line on the graph, extending the trend line backwards or forwards, setting the intercept of the trend line etc.

· To get to these options, right click on a trend line that you have already drawn on a data set and in the menu that comes up choose “Format Trendline”. 

· In the pop-up window that appears, choose the ‘Trendline Options” menu. The window then looks like the one in the screenshot given below
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· Some of the more useful controls that you have over the trend line are the following

· Display equation on the chart: checking this option makes Excel compute and display the equation on the line on the chart. This is useful for finding slopes and intercepts of the graphs.

· Forecast (Forward/Backward): The fields titled Forward and Backward Forecast on the options window can be used to extend the line forward or backward. The value in the field denotes how many times the current length of the line should it be extended. Backward forecast is useful in lab #1 for extending the velocity versus mid-point time graph so as to see the x and y intercepts. For the velocity versus midpoint time graph you will have to do a backward forecast to make the line intersect both the y and x-axis. The value in the forecast field will usually be a small number like 0.02 or 0.03 in this particular case.
A.2.6 Multiple graphs on the same sheet

· In lab #4 on conservation of energy, you will have to draw graphs with three lines on it representing three sets of data. A typical data set that you will have to plot is given below
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· Using this data set the objective is to plot (PE, (KE and (E (Columns D, E and F), all three, on the y-axis versus time (column A) on the x-axis. 

· The first step is to select the data in columns A and D (Time and (PE). It is important while attempting to plot multiple lines on the same graph that you select only the numbers and not the titles of the columns or any other cells that contain words or letters in them. In this particular case therefore you start by selecting cells A7 through A16 and then while holding down the “control” button and select cells D7 through D16. 

· Click on the Insert Tab and choose Scatter and Scatter with Only Markers as we did before. This will only plot our first series. Do not bother setting up the titles just yet. For the time being leave this chart on the same sheet as your data. 
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Now add the other series that we need. To do this click on the Chart Tools/Design Tab and click the Select Data Button a new window will appear just like below. Under Legend click Add. 
· The Edit Series window will appear and now we must fill out the 3 field by picking the appropriate data ranges. Click the Select Range button next to each field and choose the range you need. Once you have your range right click the Back to Window button next to the cell range list. In this case we are adding ΔKE so we pick that title cell for title, the time values (NOT the TIME title!) for X Values, and the actual ΔKE values for Y.
· [image: image38.png]= Chart Tools
e e e
| ==z
il W, 2O W P
Change ~ Save As iteh  Select
Chart Type Template || Row/Column Data
Type Data Chart Layouts Chart styes Loation
A7 - £ ] apE() 2
I A | B c [ b | E F G H 1 J K L M ) S r
1 |Name
2 \Lab Time
3 Lab #4 Conseation of Energy 010000
E 0.08000
Time(s) d(m)  v(ws) BPEQI]AKEQ) AE() FEtt 006000
T 0000 007 000000 000075 0.00075 215840 004000
02 0019 012 00018 000220 000033 216798
04) 0048 07 000471 000441 -0.00030 216735 002000
08 0133 026 001305 001031 0.00274 215491 0.00000 el
120 0256 036 002511 001976 -0.0053 215230
14{ 0332 040 -003257 002440 -0.00817 214348 002000 make Q)
16 0418 045 -0.04101 003088 -0.01012 214783 -0.04000
2] 0620 056 -006082 004782 -0.01300 214465 008000
24) 0864 066 008476 006643 -0.01833 213932
1.002 072 -0.09830 0.07906 -0.01924 213841 -0.08000 +
it Sries 9 [t 00000 -
012000

‘Series pame:

—Sheetiisess
Series Lvalues:
=Sheet11$A57:5AS16|
Series Y values:
=SheetlisEs7: €516

e

,0.2,0.4,0.

=0.00075, 0.002..,

[ concal

2
2
2
2%
2%
21
2
29
30
3
E0)

H
1
i

dist. v time

vel. v, mid. time

‘acceleration table

dataset 2 | Sheet1 /75 AN

g





· Next click OK and we will be back at the Select Data window. Go ahead and add the ΔE series now too by the same steps.
· Once all 3 are added we should see this for our Select Data window:
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· The advantage is that our Legend will be automatically formatted for us once we turn it on via the Chart Tools/Layout Tab. Since we have more than one series a legend is required!
· The completed sheet with three graphs on it should look as shown in the screenshot below
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· You can now select each individual series that appears on the graph and add trend lines to them as before. For lab #4 the (PE and (KE graphs must be parabolas while the (E graph should be linear.  The completed sheet with the lines is shown in the screenshot below
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